Truffle设置Solidity版本

当使用truffle开发以太坊solidity合约时,经常碰到的一个问题, 就是你的solidity合约代码所要求的编译器版本,与truffle预装的solitiy编译器 版本不匹配。本文将介绍如何更改truffle中的solidity版本。

如果要快速掌握以太坊的开发,推荐汇智网的以太坊开发系列教程

1、问题重现

由于solidity比较新,语法还在变换当中,因此你从网上找到的示范源码, 有可能已经不能通过最新版本solidity编译器的编译了。例如,当使用新版本的 truffle编译一个较早的0.4版本的合约时,就会提示编译器不匹配:

1
2
3
4
5
6
7
8
9
10
11
$ truffle migrate
Compiling .\contracts\Election.sol...
Compiling .\contracts\Migrations.sol...

/D/ethereum/electiondemo/contracts/Migrations.sol:1:1: SyntaxError: Source file requires different compiler version (current compiler is 0.5.0+commit.1d4f565a.Emscripten.clang - note that nightly builds are considered to be strictly less than the released version
pragma solidity ^0.4.24;
^----------------------^

Compilation failed. See above.`enter code here`
Truffle v5.0.0 (core: 5.0.0)
Node v8.11.1

当然可以修改原始的solidity合约代码,来响应新版solidity编译器的要求。 不过如果存在大量的历史遗留代码,这个方案会带来巨大的工作量,而且还 有很大的可能性引入新的bug。

因此,更好的办法是为Truffle项目指定Solidity编译器的版本。

2、设置truffle项目的solidity编译器版本

好在truffle允许我们指定项目中使用哪个版本的编译器,只需要在truffle项目 的配置文件truffle.js中设定compiler选项。例如,下面的配置文件将当前项目 的solidity编译器设置为0.4.24版本:

1
2
3
4
5
6
7
8
9
10
module.exports = {
networks: {
... etc ...
},
compilers: {
solc: {
version: "0.4.24"
}
}
};

你只需要在compilers.solc.version处指定要启用的solidity编译器版本就行了, truffle会自动从官方拉取相应版本的编译器,无需你手动下载配置。


汇智网原创,转载请标明出处。